Filter for Code39 Barcodes and allow manual entry for same field.


New Member
TracerPlus desktop
TC77 / Oreo

We put together a really simple TracerPlus application just to get the customer scanning inventory. They reported that when they scan, it picks up all barcodes instead of Code39 barcodes. Found the Validation checkbox to validate for Code39. Checked the box and also checked Validate immediately. That works to only pick up the Code39 barcodes but it takes away the ability to manually enter a value (instead of scanning). Is there a way to only pick up Code39 Barcodes and allow for manual entry in the same field?

Dan Peluso

Staff member

There is an advanced section in the Proiject settings that would allow you to disable other Barcode types provided you are using a Zebra Mobile device. Arguably you could also use a Variable field to detect the InputType of a given field and use that in combination with the Code39 validation to decide if it was barcode or keyboard data.

Let me know if that helps.


New Member
Thank you very much! I downloaded the latest version and now see all the Zebra support items added in July. I'll see if I can work some magic with these new settings.

Thank you again for taking the time to help!


New Member
I didn't have any luck with the settings for the symbologies. I overrode every setting and changed them to "enabled = false" with the exception of Code 39 that I enabled. I can see the settings in the XML. But, I must be missing another piece that makes it all work and/or my understanding of how it works is "off". But, your other suggestion to use a variable field did work for me. I was able to determine the barcode type coming in. Then I reworked the application to use the type to allow just CODE_39 and keyboard. Thanks again for the help!