form error


New Member
Dear TP community -

I have a few problems with behavior of a form.

1. The form consists of 3 fields CODE, TRAY, ITEM. The first 2 goto fields are the next one. For ITEM, it's TRAY (the thing is supposed to write records of CODE+TRAY+ITEM (where CODE is always the same)).
When data is scanned to ITEM, it goes to TRAY, but throws a length error, as if data from ITEM is being carried into TRAY (the fields have different acceptable length parameters). With the intention of writing a record only after an ITEM scan, Auto-submit = true just for ITEM.

2. Notwithstanding the above, it doesn't display scanned data in TRAY or ITEM (CODE has a default value (which makes it impossible to see what's causing the above length error)).

3. "Finally" - it's not writing records in the format described in #1 above.


Hi pob, chances are you've solved your problem (or worked around it) by now.

If that's not the case, I'm afraid I don't quite understand what the setup and flow is that you're trying to accomplish here. Is it possible for you to post an export of your project here so that I can have a look at what the problem is?

Dan Peluso

Staff member

I am also a little bit confused. If you have an active support agreement with us, I would encourage you to create a ticket via www, via the support menu option.

With that said, I can make a couple of suggestions.

1. It sounds like you want the data flow to be Code then focus/scan into Tray and then finally focus/scan into Item. Once the item scan is complete, you want to prompt for a newTray and Item but keep the code the same. If that is correct, you would configure the go to fields appropriately and you would also want to turn OFF the Clear on Submit option for the Code field. This option is in the After Scan Field Settings options.

2. It sounds like you are describing that when you are scanning into the Item field, the data is displaying in the Tray Field? If that is correct, I cannot think how that might happen unless you are using any kind of Smart Form rule (found in the Data Capture settings in the session) or you have some form logic set up to cause this. Aside from that, I cannot think what else might be causing this.

3. For the last item, it sounds like the record is not saving/submitting. Is it not saving simply because the validation is failing since the item and truy data is not being placed in the right spot? This one might need more clarificaiton.

As I mentioned above, the best bet might be to submit a ticket with your exported TP Desktop project attached. Also, please note if this is for Android or Windows Mobile.