On-screen key board displayed in session

Hans Bogers

New Member
After successfully using Tracerplus 7.1.1. for more than 3 years, looking now to upgrade to 9.2 and scanners running Windows CE 7.0 embedded. However during testing, the on-screen keyboard keeps on popping up. I've tested all kind of settings including a change of the registry, but no success. Therefore I downloaded a sample "Internal package track". Also with this sample the on screen keyboard keeps on popping up. The only thing that worked was switching in forms designer the input type from "any" to "Barcode" for each field, but that is no solution as it also blocks manual entry through the scanner keyboard (which occasionaly happens when a barcode cannot be read). Any ideas?

Summary:
  • Scanner MC9200, with Windows embedded compact 7
  • Tracerplus 9.2
  • Do not want to see/use the on-screen keyboard in a session, as it blocks part of the screen
  • Hiding the keyboard in a session does not work, because as soon as a field is activated the keyboard pops up
  • Tried all project settings in various combinations (disable keyboard navigation, full screen mode, Hide keyboard button, hide the menu bar; No success
  • Tried HKEY_CURRENT_USER\ControlPanel\SIP\TurnOffAutoDeploy set to 1 (see text below); No success

The on-screen keyboard will automatically display when a text box is selected based on the registry setting (dword) HKEY_CURRENT_USER\ControlPanel\SIP\TurnOffAutoDeploy. If this is set to 0 then the on-screen keyboard will automatically display. If it is set to 1, it will not. To fix this problem you can edit the registry setting. If you are using a Motorola device you can create a file in the \Application directory with a .reg extension which contains the following:

[HKEY_CURRENT_USER\ControlPanel\SIP]
"TurnOffAutoDeploy"=dword:1
 

OliverR

Member
Can anyone confirm this problem? Is this a bug with (or of) Windows CE 7.0, or only that particular device? Seems this is a show-stopping problem to move to v9.
 

Hans Bogers

New Member
Hi Joseph,

thanks for your reply, however no luck. I just followed the instructions in the above mentioned article, unzipping the .reg file, placing that file in the application root and performing a cold boot. I installed V9.2 again and started the default application. As soon as the focus is on an input field the soft keyboard pops-up again (either keyboard or XAMLIM). Using the "Hide input panel option" hides the keyboard but as soon as I tap an input field and that field becomes in focus the keyboard pops-up again. I've repeated the instruction 3 times.

Looking at the contents of the .reg file , I already used a similar .reg as mentioned in my post, however also without success.

I tried to install v7 on this device, which is brand new, but tracerplus desktop returned a message that installing V7 is not supported on the given device (I attached a printscreen with the message in Dutch).

upload_2016-7-11_23-2-22.png
 

Hans Bogers

New Member
Hi Joseph,

I did some further testing on the MC9200. There is internet explorer mobile on the device.
Also here the soft keyboard pops-up when the search box is in focus.
However when I select "Hide input panel" the input panel disappears and does not pop-up anymore.
Only when I explicitely select "keyboard" or "xamlim" again the keyboard appears again.

It looks like the .reg in the application root does not update the registry.

Regards

Hans
 

Joseph Kraebel

Administrator
Staff member
Hi Hans,

I believe the registry entry allows you to disable the popup via the keyboard options in the lower right corner and don't believe it disables it outright. If you tried to turn off the keyboard via the lower right I believe it would still keep auto popping up without this registry entry.

In regards to the V7 issue you are seeing, that is due to CE7.0 not being compatible with older versions of TracerPlus. I believe Version 8 is the minimum version that runs on CE7.
 

Hans Bogers

New Member
Hi Hans,

I believe the registry entry allows you to disable the popup via the keyboard options in the lower right corner and don't believe it disables it outright. If you tried to turn off the keyboard via the lower right I believe it would still keep auto popping up without this registry entry.

In regards to the V7 issue you are seeing, that is due to CE7.0 not being compatible with older versions of TracerPlus. I believe Version 8 is the minimum version that runs on CE7.
Hi Joseph,

Using the keyboard options at the bottom of the screen does indeed not disable it outright and in Tracerplus it even does not work as the keyboard keeps popping up after disabling.
The disabling through [HKEY_CURRENT_USER\ControlPanel\SIP] "TurnOffAutoDeploy"=dword:1 does not work either, so at this moment I am out of options.
 

Joseph Kraebel

Administrator
Staff member
Hi Hans,

Not sure why this is not working. We recently had another user with this issue on his MC92N0 and this registry file worked for him. Might be best to reach out to Zebra to see if they have any solutions to the problem.
 

Hans Bogers

New Member
Thanks Joseph,

I tried a second MC9200 but same result. In the meanwhile I found a workaround by moving up all fields to the top of the screen. The keyboard keeps on popping up but we can see the fields. Not a perfect solution but I will contact Zebra.
 

DanCara

New Member
Hans,
When you say you move fields to the top of the screen, do you do that manually or is there a setting to automatically set the next field to the top of the screen. We just started using a couple of these units and are having the same issue with the keyboard popping up. I see this thread is a few years old, has anyone found any other solutions?
Thanks
 
Top