Sync successful (with errors)

#1
On our very old scanners, Honeywell Dolphin 9900, I'm getting a sync successful (with errors) when I'm posting stored data from the handheld to our handheld to our Oracle database using an ODBC connection. The syncing of our lookup files is successful. On our newer Honeywell 99EX scanners both actions sync successfully. we deploy the same build to both scanners. Any clues? The oracle user account is NOT locked and the newer scanners work. I tried deleting and re-installing TracerPlus on the scanner and registering it but I still get this error.
 

Attachments

#2
Hi John, that message in itself does not say much. To get a better understanding of what errors or problems occur exactly you would need to have the Connect event log open (in Connect Management Studio go to the Tools menu and choose Event log). You want to set the logging level to 'Warning', and then start a sync with one of the older scanners that has the problem, while keeping the event log open.

The output of the event log may give some indication as to where the problem lies. If nothing pops out at you, you may change the logging level in the event log to 'verbose', that'll give you detailed output of all data that is being transferred. I usually want to filter that out and only look at warnings and errors, hence I choose 'Warning'.

You can easily copy and paste the output of the event log here so we can have a look at it, if you want.
 

Dan Peluso

Member
Staff member
#3
Hi,

Usually the Sync Successful (with errors) indicates that while the sync process itself was successful, there may have been some data level errors.

To identify this, you can take a look at the event log to see if anything was noted as an error during the data post itself. Additionally, you can look in your c:\ProgramData\PTS\TracerPlusConnect\SystemInfo\System folder to see if you have any files named like "Err_(timedateStamp).txt.

If you open that error file, it will have written the offending data to that file and also should offer a note/comment about what might have happened. Things like violating some DB constraint (unique key violation, etc).